pacman (Probleme auf antergos System)

  • von

Ich schaue mir gern von Zeit zu Zeit einmal andere Distributionen an und mache das entweder in virtuellen Maschinen, manchmal jedoch auch auf älterer Hardware, die nicht mehr im produktiven Betrieb ist. Hier trat nun auf einem der Systeme die derzeit an einer Art Langzeittext teilnimmt das folgende Problem auf.

root@bounty pb]# pacman -Syu pacman
 :: Synchronisiere Paketdatenbanken…
  core                                         134,1 KiB  1118K/s 00:00 [#######################################] 100%
  extra                                       1643,2 KiB  1503K/s 00:01 [#######################################] 100%
  community                                      4,9 MiB  1221K/s 00:04 [#######################################] 100%
  multilib ist aktuell
 :: Starte vollständige Systemaktualisierung…
 :: ilmbase durch extra/openexr ersetzen? [J/n] j
 Löse Abhängigkeiten auf…
 Suche nach in Konflikt stehenden Paketen…
 Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
 :: Installation vonpacman (5.2.0-2) verletzt Abhängigkeit 'pacman<5.2', benötigt von pamac

So bekam ich hier keine Updates eingespielt.
Die Lösung des Problems ist recht unspektakulär:

sudo pacman -Rdd pamac

danach ist es mittels

pacman -Suy

wieder möglich Updates einzuspielen

Schlagwörter:

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.